LDAP authentication for a user

Rajesh Dharmalingam rajesh.dharmalingam at gmail.com
Mon Dec 31 06:18:09 UTC 2007


I made the authentication work for the previous post. Now, i am facing with
one more problem with the following schema:

dn: cn=rajeshtest, cn=authenticated users, cn=abc, o=rajesh.com
authenticationuserpassword: rajeshtest
defaultcontext: o=test,cn=abc,o=rajesh.com
userPassword:: rajeshtest
description: rajeshtest
objectClass: top
objectClass: authenticationuser
cn: rajeshtest

configuration file:
  <Plugin DJabberd::Authen::LDAP>
        LDAPURI             ldaps://ip:port/
        LDAPBindDN       o=rajesh.com <http://a1.com/>
        LDAPBindPW      ****
        LDAPBaseDN      cn=authenticated
       LDAPFilter            (cn=%u)

ldap change:
     In ldap search, included the scope as sub for searching.

When i try to authenticate this user with the above mentioned
configuration/changes, I am not able to login? Is there anything i need to
include in filter or in base dn. Basic difference between the previous
schema and this schema is, i have a default context.

Thanks and Regards,

On Dec 28, 2007 8:08 PM, Rajesh Dharmalingam <rajesh.dharmalingam at gmail.com>

> Hi,
> I have a user who needs to be authenticated:
> The ldap schema looks as below:
> dn: cn=a, cn=authenticated users, cn=abc, o=a1.com
> authenticationuserpassword: ****
> userPassword:: #######
> description: test
> objectClass: top
> objectClass: authenticationuser
> cn: a
> As mentioned below, I provided in the djabberd conf file, and tried to
> login using the user a but the result is - user is not found...
>  <Plugin DJabberd::Authen::LDAP>
>         LDAPURI             ldap://ip:port/
>         LDAPBindDN       o=a1.com
>         LDAPBindPW      ****
>         LDAPBaseDN      cn=authenticated users,cn=abc,o=a1.com
>        LDAPFilter            (cn=%u)
>   </Plugin>
> When i give the same from a ldap browser as below, i am able to find the
> dn for this user
> Search dn: cn=authenticated users,cn=abc,o=a1.com
> Filter: cn = a
> I get the dn for this user.
> I tried with adding scope as 'sub' in the ldap plugin which gives the same
> result.
> One more thing is, SSL is required for ldap. so i did the required changes
> to the ldap plugin in djabberd and tried. I am getting the same result that
> "account a not found"..
> Can you provide some input?
> Regards,
> -Rajesh


"Stick to our roots and not to forget where we come from"
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.danga.com/pipermail/djabberd/attachments/20071231/23760693/attachment.html 

More information about the Djabberd mailing list