bind(): Can't assign requested address

Christopher Schmidt crschmidt at
Mon Nov 22 19:21:26 PST 2004

Having some problems getting to the list from my mail server; trying 
again with a different address.

On Mon, Nov 22, 2004 at 05:23:03PM -0800, Dave Roe wrote:
> I am trying to get memcached (1.1.11) running under OS X (10.3).
> ld: warning -L: directory name (/lib) does not exist

I get this as well - however, it's not limiting. It would normally be 
/usr/lib; This may be a problem somewhere in configure.
> Nevertheless, the binary is created. I then proceeded with "sudo make 
> install".
> /bin/sh ./mkinstalldirs /usr/local/bin
>   /usr/bin/install -c  memcached /usr/local/bin/memcached
> make  install-man1
> /bin/sh ./mkinstalldirs /usr/local/man/man1
>  /usr/bin/install -c -m 644 ./doc/memcached.1 
> /usr/local/man/man1/doc/memcached.1
> install: /usr/local/man/man1/doc/memcached.1: No such file or directory
> make[2]: *** [install-man1] Error 71
> make[1]: *** [install-man] Error 2
> make: *** [install-am] Error 2

I didn't have this problem in the most recent CVS.

> Okay, this is just the man page, so I figured I could still proceed, 
> but I am unable to start memcached using "sudo /usr/local/bin/memcached 
> -l -p 11211 -m 64 -d". It fails with:
> bind(): Can't assign requested address
> failed to listen

I got this using both and another internal IP address.
> My machine has an internal IP of which I tried. No change. I 
> tried various different values for the port. No change. I ran netstat 
> but could not see anything which would indicate a port number conflict.

Running it with no -l worked here:

./memcached -d -m 128 -p 11211

Does that work for you?

Christopher Schmidt
crschmidt at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url :

More information about the memcached mailing list