[announce] php: mcache extensions 1.1.0

John McCaskey johnm at klir.com
Thu Feb 17 10:06:16 PST 2005

On Fri, 2005-01-28 at 13:04 +0200, Philippe Cabannes wrote:
> Hi John,
> I installed mcache without problem, but when i ran the piece of code
> provided on your website,  Php just returns "Call to undefined
> function pmemcache()". Then i tried to execute only basics operations
> and got this "Unable to perform memcache->set()".
> Still functions memcache() & add_server() appears to work fine...
> I tried both installations: as a module and compiled in php, mcache
> extension gets loaded in both cases.
> I also tried different versions of libmemcache & mcache, the result
> remains the same.
> Any idea why it does not work properly?

Very strange, I'm not sure what would be causing this.  Can you provide
some additional info on your setup?  

1) PHP Version
2) mcache extension version (latest 1.1.2 I assume?  The original
versions did not include pmemcache() support.)
3) libmemcache version
4) php configure string (find it with phpinfo()), and list of additional
runtime modules loaded
5) Apache version and if 2.x worker model (ie pre-fork, threaded, etc)
6) Any errors that may be appearing in the apache error log file

Also check in phpinfo() that the mcache module is listed and has the
right version number output to verify it is loading correctly.  The only
thing I can really think of is that maybe you have mcache as well as the
PECL memcache modules loaded and they are conflicting as they use some
of the same function names, or possibly you have one version of mcache
compiled in, and are dynamically loading a newer or older version and
they are conflicting.

John A. McCaskey
Software Development Engineer
Klir Technologies, Inc.
johnm at klir.com

More information about the memcached mailing list