call for testers

Jacques Caron jc at
Mon Sep 4 22:07:27 UTC 2006


Tried on FreeBSD 5.4 i386 and amd64 and I can't even compile the 
thing out of the box. Configure complains it can't find libevent even 
when it's present, and log seems to indicate prefix is "" even if I 
try to force it to /usr/local, which is supposed to be the default anyway:

configure:2996: checking for event_set in -levent
configure:3026: gcc -o conftest -g -O2 -I/include   -L/lib conftest.c 
-levent   >&5
/usr/bin/ld: cannot find -levent

I guess the problem is somewhere around:

# Check whether --with-libevent or --without-libevent was given.
if test "${with_libevent+set}" = set; then

if test "$with_libevent" != "no"; then
         CFLAGS="$CFLAGS -I$with_libevent/include"
         LDFLAGS="$LDFLAGS -L$with_libevent/lib"

./configure --with-libevent=/usr/local works, though, but it should 
default to $prefix...

Compilation gives these warnings:

items.c: In function `item_link_q':
items.c:143: warning: comparison is always true due to limited range 
of data type
items.c: In function `item_unlink_q':
items.c:161: warning: comparison is always true due to limited range 
of data type

Once compiled, prove test fails (and hangs), and prove -v test says:

 > prove -v test
ok 1 - started the server
not ok 1 - stored foo

#     Failed test (test/getset.t at line 14)
#          got: undef
#     expected: 'STORED
# '
not ok 2 - foo == 'fooval'

#     Failed test 
(/usr/home/jc/memcached-1.2.x-svn357/test/lib/ at line 52)
#          got: undef
#     expected: 'VALUE foo 0 6
# fooval
# '
(and hangs there forever)

Everything exactly the same on i386 and amd64.

Let me know if you need any further testing...


At 23:37 04/09/2006, Brad Fitzpatrick wrote:
>Before I do a release, can I get some people running the test suite on
>this snapshot?
>   -- ./configure
>   -- make
>   -- prove test
>      -- if all good (you see at bottom:  "All tests successful, ...."),
>         let me know.
>      -- if bad, reply with "prove -v test", which will show verbose
>         per-test output
>Looking for:
>   -- Various Linux Distros (I've tried Debian and CentOS)
>   -- Solaris 10 (my Nexenta VM is failing to boot again)
>   -- FreeBSD
>   -- OS X
>   -- 64-bit whatevers (I did test it on 64-bit CentOS)
>Let me know of any quirks, even if they're not part of the tests.
>- Brad

More information about the memcached mailing list