Mike South msouth at
Mon Jan 21 18:18:08 UTC 2008

On Jan 21, 2008 10:45 AM, Scott Tamosunas <tamosunas at> wrote:
> Hi Jehiah,
> Thanks for the info. I am not directly connecting to memcached, I am using
> the Ruby memcache-client gem via cache_fu. When I run this code locally, it
> works as desired. It's only when I deploy to the production shared server
> that this error appears.


what Jehiah was telling you is that the output you pasted in shows
that some client (appears to be a Safari browser) is making an http
request to your memcached server.

 All those lines that have the < in front, starting with the GET line
down to X-Forwarded-Server line, are lines coming "in" to memcached.
Memcached is expecting to get memcache commands or queries, but
instead it's getting a request from an http client, which thinks it is
talking to a web server.  When memcached sees each line, it checks to
see if it's a memcached command, and it isn't.  It responds with
ERROR.  That's what the lines marked with > show.

Essentially, the browser is looking for groceries, but it's going to
the post office for them.  The post office is telling you "ERROR: I
don't have any lettuce.  I don't know what you are talking about".

You need to figure out why the memcached on your FC5 box is getting
HTTP requests.  (I'm guessing you can get this behavior by starting up
memcached listening on the port that the web traffic is supposed to be
coming in, but I've never tried that, for what would hopefully be
obvious reasons.)

Perhaps you can look at the one you say you have working on FC5 and
check for differences in your configuration


> Scott
> On 1/20/08, Jehiah Czebotar <jehiah at > wrote:
> > When you use -vv you are seeing debuging information. The first number
> > is the connection id, and each pair of lines is what the server reads
> > as a request and it's response.
> >
> >
> > > <7 new client connection
> > > <7 GET / HTTP/1.0
> > > >7 ERROR
> >
> > From the lines you included it is clear that some http client (or
> > browser) is trying to connect directly to memcached, and this happened
> > to be the 7th connection. You can't use a http client to connect to
> > memcached and should use one of the client libraries available.
> >
> >
> > --
> > Jehiah
> >

More information about the memcached mailing list