issues in multiple memcached instance on freebsd

Ian Lord mailing-lists at
Tue Mar 25 11:42:47 UTC 2008

From: memcached-bounces at
[mailto:memcached-bounces at] On Behalf Of golak Sarangi
Sent: 25 mars 2008 03:20
To: Dustin Sallings
Cc: memcached at
Subject: Re: issues in multiple memcached instance on freebsd

Memcached is listening only in one port. But still the other port shows
'address already in use'. This happens only in freebsd. Is this a bug that i
hit upon?
On Tue, Mar 25, 2008 at 11:12 AM, Dustin Sallings <dustin at> wrote:

On Mar 24, 2008, at 22:26, golak Sarangi wrote:

> I have been using memcache on a freebsd system smoothly for few
> months. But now on trying to start two instances of memcache on same
> system but on different port i get the following errors
> bind(): Address already in use
> failed to listen
> I am using port 11211 and 11212 for two instances. there is nothing
> else running on those ports.
> i tried the same thing on debian system and it worked fine.
> Could anyone guide me through it?
       I'd expect the following command to show you something listening

       netstat -an | grep 11211

       If you have lsof, ``lsof -i | grep LIST'' should show you listening
sockets and the processes that are listening on them.


I am running freebsd and I can start multiple process on different ports
/usr/local/bin/memcached -l -m 128 -p 8887 -u xxxx &
/usr/local/bin/memcached -l -m 128 -p 8888 -u xxxx &
/usr/local/bin/memcached -l -m 128 -p 8889 -u xxxx &
Without any problem
 if it’s a bug, it has something to do with another
factor, not just freebsd

More information about the memcached mailing list