Getting started, Bad file descriptor

Kevin Lewandowski kevin at
Thu Jul 28 11:53:58 PDT 2005

Okay, I've installed Perlbal 1.3 (fyi, it seems to be missing, I had to get that out of CVS).

With aio_mode set to none I get the same error. With aio_mode set to  
ioaio I get the error: "ERROR: IO::AIO not available"

Does that mean I'm missing something? I do have Linux-AIO-1.72  


On Jul 26, 2005, at 1:52 PM, Mark Smith wrote:

>> Hi, Mark. I did that and still get the same result. thanks
> Okay.  We've just made a release (1.3) of Perlbal that has lots of  
> changes
> in it.  Can you try going and getting that, then installing it?
> Once you've got it installed, try running it with aio_mode set to  
> 'ioaio'
> or 'none' and see if either of those work now.  The new version has  
> a bunch
> of changes to how we handle asynchronous IO.
> If that still doesn't work, then it'd be useful to do an strace of the
> mogstored and try to find where it's erroring in the call to open 
> ().  You
> may have to start inserting debugging in the part of the code that  
> prints
> the internal error message, and try to find out why it's screwing up.
> If you're not familiar with the best way to go about doing these,  
> let me
> know and I can provide more detailed information.  :)
> --
> Junior (aka Mark Smith)
> junior at
> Software Engineer
> Six Apart / Danga Interactive

More information about the mogilefs mailing list