buffer_on_rate: buffer file exists test failure

Jay Buffington jaybuffington at gmail.com
Thu Jun 8 00:51:15 UTC 2006

I'm trying to install Perlbal 1.41 and one test is failing:

[jay at zwa1 Perlbal-1.41]$ perl t/45-buffereduploads.t

ok 16 - clean_on_early_close: no file
not ok 17 - buffer_on_rate: buffer file exists
#     Failed test (t/45-buffereduploads.t at line 214)
ok 18 - buffer_on_rate: good response

[jay at zwa1 ~]$ cat /etc/redhat-release
Red Hat Enterprise Linux ES release 4 (Nahant Update 3)
[jay at zwa1 ~]$ perl -v

This is perl, v5.8.5 built for i386-linux-thread-multi

I ran the test several times one after another and it succeeded once.
Is it possible that the directory is getting deleted too quickly?

All other test succeeded.  I also tried with the latest version from
svn and got the same failure.

Also, in my Perlbal config I have:

  SET buffer_uploads               = true
  SET buffer_upload_threshold_rate = 0
  SET buffer_upload_threshold_size = 0
  SET buffer_upload_threshold_time = 5

Since I'm not using buffer on rate, does it matter that that test failed?


More information about the perlbal mailing list