memcached overrides memory limit

Olga Khenkin olga at
Thu Nov 2 16:17:21 UTC 2006

Hi all, 


I have the following problem with memcached: I run it with certain memory
limit, let's say -m 300 (300 Mb). In a few hours it reaches 370 Mb and
continues to grow. 

When I get stats from this instance, it shows max_available between 300 and
320 Mb, and bytes_used about 220 Mb. What happens with the rest of memory?


Our site works with memcached through PHP Memcache extension, in an array of
20 instances working together. It works with huge number of connections, so
I would suspect connection structures of eating the memory, but in times of
relatively low traffic, when connections get released, the memory is not.

We basically use version 1.1.12, but today I tried 1.2 and met the same
problem. So if it's a bug in memcached, it wasn't fixed. But maybe I just
use it the wrong way?


Maybe somebody got the same problem? Or maybe you have any ideas about the
cause of this memory issue? We're happy to use memcached, but with those
memory issues we have to restart it every few days and, naturally, lose all
cache at restart.


I will be grateful for any ideas, before I enter deep debugging.



-------------- next part --------------
An HTML attachment was scrubbed...

More information about the memcached mailing list