Danga::Socket, epoll, resolved. New Problem: ports numbers!

Justin Azoff JAzoff at uamail.albany.edu
Thu Jul 14 07:30:47 PDT 2005

On Thu, 2005-07-14 at 01:12 -0400, j.ignacio.leon at gmail.com wrote:
> Thank you for your reply!
> > file uploading is a 3 stage process.
> >... 
> > you can check to see if the mogstored is working or not by just trying
> > to upload and download a file from it, it's nothing special.  Barring a
> > permission problem, it is probably working fine.
> So just telnetting into any of the mogstored boxes to the port that I
> set as the data_port (7200) and doing what HTTP operation? Put?

yep, PUT and then GET

> > my guess is that your host table in the database still references port
> > 7500.  Also, since you never mentioned port 7501, you probably have to
> > fix that too.  7501 is only used for the size request, and would only
> > cause a slight slowdown if broken anyway.
> Actually, the host table is correct, I changed it to (7200). However,
> after I sent the email I noticed that 7501 was hard coded, so I caught
> that one too.
> > You should be able to enable debugging in mogtool to see what port it
> > tries to connect to.
> I am working on this one... great tip. I now see that I am getting a
> HTTP 500 error when trying to save a file with mogtool... which means
> your initial guess of broken mogtools seems to be correct.
> I have a feeling that the document root is giving me troubles now. In
> some places due to the NFS remnants it seems it was different.  I have
> tried to set it to /var/mogdata everywhere but I am running out of
> ideas on how to further troubleshoot this.

the docroot for the client is also stored in the host table, but I think
the servers is hardcoded in mogstored

> For mogtool, the tracker port I have set is 7001 which is what I told
> mogilefsd to use as... I set 7201 to be the other (control?) port
> (used for get size and what else?).  Am I still missing another port
> that I need to specify?


> > > Any Ideas?  The changing back and forth of ports from the
> > > documentation, sample conf. files from cvs and the binaries has me all
> > > mixed up.
> > 
> > why not just use the defaults?
> Because there are inconsistencies between what the webpage example
> conf has (port 6001 for mogilefsd conf_port) vs the CVS conf files
> (7001).  Also, the root changes from place to place... /var/mogdata
> vs. /mnt/mogilefs

yeah, but if you didn't change anything it would have worked.

> I have all set to /var/mogdata
> mogilefsd listening on 7001 as conf_port
> mysql host lists 7200 as the http port for hosts
> mogilefsd 7201 MOGSTORED_STREAM_PORT 
> ---
> mogstored listening on 7200 as data port
> 7201 set in mogstored to data_stream
> IO::Socket::INET->new(LocalPort => 7201, # FIXME make this configurable
> worker_port 7200
> --
> mogtool talking to tracker via 7001
> Does this look correct?

since you get the tempfile entries in the database the client->tracker
communication is working fine.

$ mogtool  --debug inject /etc/motd /etc/motd

and see where it goes wrong, or just post the output to the list if you
can't figure it out.

-- Justin Azoff
-- Network Performance Analyst

More information about the mogilefs mailing list