mogilefsd cannot see mogstored's running

Mark Smith junior at
Fri Jul 15 16:34:11 PDT 2005

> The perl call Mark sent me works when run as root (which is what I am
> running mogstored as).  I went so far as to make /var/mogdata chmod
> 777.

Damn.  There goes that idea.

> The reason I am running old perlbal code is because it builds and
> passes make test without problems. The current CVS version does not.
> Also, it was the one that is linked from the website.

'make test' fails because it's unable to create directories/files.  If you
look at the test that was failing (20-put.t), that test does all sorts of
things relating to creating files, etc.

In those tests, it's using a temporary directory which should be
writable... the fact that it's failing seems to indicate some sort of
incompatibility with our code and your system -- but at what layer, I don't

It seems safe to say that we can rule out a configuration problem at the
mogstored level as well as any permissions problems.  That leaves the very
real possibility that the code is just not going to work on your machine as
is, for some reason.

The closest thing I have to a RH4 test environment is Fedora Core 3.  I
just ran the latest Perlbal test suite, and it worked fine.  Slight epoll
issue, but I disabled epoll for the test, and it worked.

My suggestion is that you try to dig down into the code and follow it and
try to debug it.  If you can figure out why it's not working, and it's a
code issue that can be corrected, we'd gladly take a patch and get it
committed and credit you.

Other than that, I don't know.  I'm sorry that it's not working for you.

Junior (aka Mark Smith)
junior at

Software Engineer
Six Apart / Danga Interactive

More information about the mogilefs mailing list