mogilefsd cannot see mogstored's running

j.ignacio.leon at j.ignacio.leon at
Mon Jul 18 09:22:24 PDT 2005

> Actually, just thought of something else... try this:
> Edit lib/ and change this section:
> $Perlbal::AIO_MODE = "none";
> $Perlbal::AIO_MODE = "ioaio" if $Perlbal::OPTMOD_IO_AIO;
> $Perlbal::AIO_MODE = "linux"  if $Perlbal::OPTMOD_LINUX_AIO;
> And comment out the second two lines:
> $Perlbal::AIO_MODE = "none";
> #$Perlbal::AIO_MODE = "ioaio" if $Perlbal::OPTMOD_IO_AIO;
> #$Perlbal::AIO_MODE = "linux"  if $Perlbal::OPTMOD_LINUX_AIO;
> (ed note: should really be a way to force the AIO mode you want...)
> Anyway, that will force it to use 'none' mode.  Then try running mogstored
> again and using the curl test.

I synced to the latest CVS versions of everything this morning and
made the above changes to force AIO to none.

It worked !! --  ( well, sort of ) The folders were created when using
curl, that problem is gone. Things also worked with mogtool as long as
the file did not exceed the chunk size. As soon as that happened
mogstored would crash hard and exit:

crash log: Offset outside string at
/usr/lib/perl5/site_perl/5.8.5/Perlbal/ line 66.

This line is in aio_write function of
I have added prints and it seems as long as the length of the file is
small, the code works as expected (both with curl and mogtool inject).

Any other ideas at this point?

I will be installing gentoo and/or debian on a couple test machines
this afternoon to see if I can solve things by just switching distros.

Thanks for all the help along the way folks.

More information about the mogilefs mailing list