MogileFS.class.bin error

drpr0ctologist at drpr0ctologist at
Mon Aug 20 10:09:38 UTC 2007

I'm trying to decide whether to use the MogileFS.class.bin php file:

Or the MogileFS PHP Extension here:

Do you guys have any feedback on which is better to use?

Also, I tried using MogileFS.class.bin and am getting this error message:

*Fatal error: Uncaught exception 'Exception' with message
> 'MogileFS::doRequest ERR unreg_class unreg_class' in /www/htdocs/fs.php:213
> Stack trace: #0 /www/htdocs/fs.php(353): MogileFS->doRequest('CREATE_OPEN',
> Array) #1 /www/htdocs/fs.php(396): MogileFS->setResource('wtf', Resource id
> #4, 12) #2 /www/htdocs/fstest.php(19): MogileFS->set('wtf', 'who is this?')
> #3 {main} thrown in /www/htdocs/fs.php on line 213*

 Here's the script I tried running:

<html><head><title>PHP Test</title></head>


// Usage Example:
$mfs = new MogileFS('testdomain', 'testclass', 'tcp://');
$start = microtime(true);
$mfs->set('wtf',  "who is this?");
printf("EXISTS: %d\n", $mfs->exists('wtf'));
print "<br>GET: [" . $mfs->get('wtf') . "]\n";
$stop = microtime(true);
printf("<br><br>%.4f\n", $stop - $start);

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the mogilefs mailing list