mogilefsd does not start anymore [solved]

sanados sanados at
Thu Apr 10 05:17:43 UTC 2008

was on the test-setup
currently two

Jonathan Steinert wrote:
> That fid (leftmost column) looks like a 32bit maxint, I'm going to 
> wager that your AUTO_INCREMENT on tempfile is pegged all the way at 
> the highest value it can be.
> If you really have that many files, then you'll need to switch to 
> 64bit fids... or this could be a sign that you tried to supply your 
> own fid during file creation and passed in an integer too big for your 
> mysql setup.
How to switch to 64bit fids?
Enough to change db coloum or do i need to adjust mogilefs too?
in production enviroment i tink we will reach that max in about 8 months.
> I've seen this happen before, please expand on your setup a bit... 
> number of files, how you create the files, and what sort of machines 
> you're running this on.
it was the max of int ...

1) mysql sock was missing
2) killed one index too much ... after crash i got a pair of dmid and
dkey ... that killed the startup i guess ... as excatlly this pair was
in tempfiles too.

1) link /tmp/mysql.sock to /var/run/mysqld/mysql.sock
2) update ndbcluster from 5.0.22 to 5.1.23
    setup new db and imported old db after cleaning that defect pair.
    (mogilefs db setup will not work on 5.0.22 ndb ... though it runs
fine on 5.1.23)

ndb_mgm> show
Cluster Configuration
[ndbd(NDB)]     2 node(s)
id=10   @  (Version: 5.1.23, Nodegroup: 0)
id=11   @  (Version: 5.1.23, Nodegroup: 0, Master)

[ndb_mgmd(MGM)] 2 node(s)
id=1    @  (Version: 5.1.23)
id=2    @  (Version: 5.1.23)

[mysqld(API)]   2 node(s)
id=20   @  (Version: 5.1.23)
id=21   @  (Version: 5.1.23)

> --hachi
> sanados wrote:
>> MySQL self-tests failed.  Your DBD::mysql might've been built against 
>> an old DBI version.
>> any1 seen this error message before and/or know how to solve that?
>> did not change anything on my system, except a svn update and recompile.
>> (side note: had to kill some index from base tables for i use 
>> ndbcluster)
>> rebuilt DBD::mysql and DBI already
>> i find that row in the table tempfile:
>> | 4294967295 | 1207551042 |       0 |   99 | 
>> _server_startup_test         | NULL   |
>> when i delete that row i can start up mogilefsd ... though the 
>> tracker will not answer my calls.

More information about the mogilefs mailing list