Tracker cannot find a file even if it is present on the devices !

Dinesh Gadge dinesh.gadge at
Wed Feb 27 17:00:29 UTC 2008

Hello everybody,
I am using the ruby mogilefs-client library to interact with my mogilefs

It has happened on a few occasions that after storing a file with a
particular key, tracker does not recognize the key, and returns nil on using


where key is the key of that file.

This is an irreproducible [and hence an annoying :( ] problem [at least for
When I checked up, the file had a correct entry in the db, with the correct
key and devids.
On checking up the /var/mogdata directory for the corresponding devices, the
file was present.

Still, it seems, the tracker is unable to find the file using that key.
I have tried it with the perl client too, even it gives an 'undef' on asking
for the file using get_file_data with the corresponding key.

I have tried 'list_keys' on both ruby and perl client .. and the result does
not have any entry for the given key.

My question is .. is this a known issue ?
or is it something I experienced randomly ? (on more-than-one occasions

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the mogilefs mailing list