Tracker cannot find a file even if it is present on the devices !

dormando dormando at
Wed Feb 27 20:32:58 UTC 2008

First I've heard of this.

Any chance you could send the list (or me privately) the some of the 
rows from your database?

SELECT * FROM file WHERE fid = brokenfid;
SELECT * FROM file_on WHERE fid = brokenfid;

maybe what's in domain, devices tables. devices would be more important.

I suspect there might be no file_on rows associated with it, or it's 
failing the paths test somehow.

You can try fetching the key with the 'noverify=1' option set and see if 
it returns paths (that may not work). By default mogilefs will try a 
HEAD request against the storage node for each path, and filter by what 
paths actually work. This is even probably a better suggestion to test 
than sending me parts of your database.


Dinesh Gadge wrote:
> Hello everybody,
> I am using the ruby mogilefs-client library to interact with my mogilefs 
> installation.
> It has happened on a few occasions that after storing a file with a 
> particular key, tracker does not recognize the key, and returns nil on 
> using
> get_file_data(key)
> where key is the key of that file.
> This is an irreproducible [and hence an annoying :( ] problem [at least 
> for me].
> When I checked up, the file had a correct entry in the db, with the 
> correct key and devids.
> On checking up the /var/mogdata directory for the corresponding devices, 
> the file was present.
> Still, it seems, the tracker is unable to find the file using that key.
> I have tried it with the perl client too, even it gives an 'undef' on 
> asking for the file using get_file_data with the corresponding key.
> I have tried 'list_keys' on both ruby and perl client .. and the result 
> does not have any entry for the given key.
> My question is .. is this a known issue ?
> or is it something I experienced randomly ? (on more-than-one occasions 
> though)
> -- 
> Regards,
> Dinesh

More information about the mogilefs mailing list