install on Solaris?

Colin Murtaugh cmurtaugh at
Thu Apr 21 12:48:28 PDT 2005

Thanks for the tip; I discovered that there was an unresolved symbol  
error being generated by the libevent test:

Undefined                       first referenced
  symbol                             in file
ld: fatal: Symbol referencing errors. No output written to conftest

which I was ultimately able to resolve by setting some CFLAGS:

export CFLAGS='-lsocket -lmalloc -lresolv'

as mentioned in this post:

I also had to change test/ to use bash instead of sh on my  

Seems to be working now!


On Apr 21, 2005, at 12:49 PM, Evan Martin wrote:

> Check out config.log and try to find the context near where it spat
> out that error message.  Before it there ought to be logged some
> attempt at compiling a test program that uses libevent.  Either try to
> figure out why that failed, or paste it here and I'll take a stab at
> it.
> On 4/21/05, Colin Murtaugh <cmurtaugh at> wrote:
>> Hi --
>> Can anyone give me any pointers on getting memcached to build on
>> Solaris 8? I can't get past this error when trying to configure:
>> configure: error: libevent is required.  You can get it from
>> I've already installed libevent, but can't get the memcached configure
>> script to see it.  I've tried using the --with-libevent param but I
>> still get the same error.
>> Let me know if I can provide any other useful information.
>> Thanks-
>> Colin

More information about the memcached mailing list